Problème d'installation avec MyBLitzortung


  • Participant

    Bonjour et bonne année 2015 au passage ;).

    J'ai un problème lors de l'installation des script de MyBlitzortung. J'ai ce message d'erreur:
    Error: You must remove all blank lines and spaces before <?php and after ?> in config.php !!!

    J4ai relu plusieus fois le fichier config.php et j'ai même supprimé tous les espaces commentaires, rien à faire j'ai toujours le même message d'erreur.

    Mon serveur tourne sur un Raspi sous Apache.

    Quelqu'un sait quel pourrait être le problème?
    Merci d'avance.

  • Admin

    Salut,

    Le message est pourtant clair. Il ne peut pas y avoir de ligne vide avant et après les balises php.

    Regarde si ton code n'est pas du style: [code]<?php blabla ?> [/code] Ou
    [code] <?php blabla ?>[/code] Sachant que la version correcte est: [code]<?php blabla ?> [/code]

  • Participant

    J'étais un peu fatigué, je me suis mal exprimé.
    En fait, je n'ai aucun espaces en début et fin de fichier. J'ai même fait le test de supprimer absolument tous les espaces et commentaires du fichier. Sans aucun résultat, j'ai toujours le même message d'erreur.
    J'ai fait également le test de supprimer des lignes, afin de voir si j'éditais bien le bon fichier. Pas de soucis de ce coté.

  • Admin

    Donnes un lien vers ton config.php pour que l'on puisse le télécharger ou renome le en config.txt et mets le sur le forum en enlevant les infos confidentielles 😉

  • Participant

    Voilà le lien:

    https://drive.google.com/file/d/0B6ZUAxjJyPXRd0psZTliMkFlX00/view?usp=sharing

  • Admin

    Étrange, tout a l'air correct.
    Quelques remarques en passant. Ne mets pas de " " pour les valeurs numériques.
    Tu devrais utiliser un autre user que root pour ton accès à la db, pas très secure...


    Envoyé de mon iPad à l'aide de Tapatalk

  • Participant

    J'étais persuadé d'avoir répondu, Bref!

    J'ai tenté en enlevant les guillemets ça ne résout pas le problème.
    Est ce que le répertoire dans lequel j'ai fait mon installation pourrais avoir un impact?

  • Admin

    Bon... j'ai téléchargé ton fichier de config. Il y a bien une ligne vide à la fin du fichier.

    J'ai testé ton fichier tel quel sur une nouvelle installation: j'obtiens bien l'erreur de ligne vide.
    Après l'avoir supprimée, l'installation se poursuit correctement.

  • Participant

    C'était ça!
    C'est à n'y rien comprendre. J'avais vu cet espace et je l'avais supprimé. Que s'est il passé après, me suis je loupé lors de la sauvegarde mystère!?!
    C'est pour ce genre de chose que j'aime bien avoir la numérotation de lignes, ça saute aux yeux. Ce n'est pas le cas de gedit.

    Merci!

  • Participant

    Pour info j'ai trouvé le coupable : c'est gedit.
    Je ne sais pas pourquoi mais à chaque fois que j'enregistre il rajoute un espace à la fin et impossible de le voir si on le ré-ouvre avec lui. Pour m'en apercevoir j'ai utilisé SciTE.

  • Admin

    Super.

    Sous Windows j'utilise Notepad++ sur Unix c'est plutôt vim.

  • Participant

    [quote="clement104"]Super.

    Sous Windows j'utilise Notepad++ sur Unix c'est plutôt vim.[/quote] +1
    Notepad++ est vraiment très bon.

  • Participant

    [quote="clement104"]Super.

    Sous Windows j'utilise Notepad++ sur Unix c'est plutôt vim.[/quote]
    +1
    Notepad++ est vraiment très bon.

Log in to reply